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About QGIS
QGIS  is  OpenSource  software  developed  by  an
open  community,  by  various  commercial  and
governmental organisations around the world. New
versions  (with  bug  fixes)  are  released  frequently.
This guide is designed for QGIS 2.6.0.

It is available to download at http://www.qgis.org/

The  full  user  guide  can  be  found  here:
http://www.qgis.org/en/site/forusers/index.html

Sources of Free Map Data
Free (as in speech/beer) data sources:

OS Open Data but must attribute Crown Copyright if redistributing: 
https://www.ordnancesurvey.co.uk/opendatadownload/products.html
Various raster map scales and vector data, including height, contours etc. Does not display plot
boundaries.

Shuttle data (NASA scan of the globe, elevations): http://www.sharegeo.ac.uk/handle/10672/5

OpenStreetMap: http://www.openstreetmap.org/export
Vector files are free to download (check re-use permissions but I think it's free) showing roads,
buildings, paths, field boundaries, woods.... but will be in lat/long coordinate system. Shouldn't be a
problem to display them as background layers though.

Paid OS data (more detail, field boundaries etc.): http://www.centremapslive.co.uk/page/home
...or other suppliers, pricing schemes vary. ~£15 for 1:10000 raster image covering 1km x 1km.

Introduction

This is a brief introduction in to the way QGIS manages data. Don't worry if this is confusing at first,
it's not essential yet and working through the examples should make things clearer!

Raster vs. Vector

QGIS uses two types of graphical data. The first is called  Raster with images represented as a
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series of cells or pixels, each with a colour value. Imagine a TV screen up close, you can see each
pixel individually but as a whole they make up an image. Raster images can only be 'zoomed in' to
a certain point before all you can see is the individual pixels/cells. The mapped size of each pixel
for a layer is called the  resolution. So a 1:10000 OS map might have pixels that are 5m across
while a 1:50 plan might have pixels that are 5mm across. QGIS can display both together but as
you zoom in closer, the pixels become more apparent.

The second kind of data is called Vector data. This is where shapes or information are not stored in
a rigid pixel arrangement but instead the values of points along a line or area are recorded 
precisely. If you zoom in on a vector line on a computer, the line is redrawn and so always appears 
sharp, never pixelating. This does not necessarily mean the line is precise but it can be displayed 
on screen at any scale.

Summary

Raster data Vector data

• Made up of pixels
• Generally image data: maps, aerial 

photos
• Fixed resolution: pixelates when zoomed

in too far

• Made up of points and lines
• Points, lines, polygons
• Can 'zoom in' continuously

• Map images/scans
• Aerial photographs
• Scanned site drawings

• Map data
• GPS/survey data
• SatNav roads & traffic

File types

Each layer in GIS is a reference to a file containing that layer's data. QGIS will usually display the 
following file types with little trouble. With plugins and tweaking it will open most other formats too.

Raster Vector

.tiff Image (GeoTIFF), image data, usually 
coloured and georeferenced*. Can be 
compressed.

.shp Shapefile, gives shapes (1 of points, lines 
polygons) and attached table data

.asc Non-coloured pixel data – e.g. heights 
above OD in an area. Pixels can be colour
coded later to represent heights

.gpx Point or line data recorded by hand held 
GPS

.dxf CAD data (in Drawing eXchange Format), 
contains points, lines and polygons
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*more on georeferencing later – it means the pixels have a location on the map, rather than floating
nowhere. Non-georeferenced images will load up at 000000 000000, somewhere off Land's End! 
For now all data we are using will be georeferenced.

Shapefiles

Shapefiles are a standard format developed by ESRI (creators of ArcGIS etc.) but used by most 
GIS software.

Each shapefile is made up of 3 (or more) helper files with the same name but different extensions. 
You only need to add the main .shp file to a project and the rest happens behind the scenes.

QGIS Layer name (Easterngate Example) ArchFeature Excavated Slot

.shp Contains polygon data ArchFeature.shp ExcavatedSlot.shp

.dbf Table of attributes for each shape ArchFeature.dbf ExcavatedSlot.dbf

.shx System index of shapes (don't touch) ArchFeature.shx ExcavatedSlot.shx

.prj Projection information* ArchFeature.prj ExcavatedSlot.prj

* more on projections and coordinate systems to follow.

This becomes a handful, so it is important to keep your files organised! Note that if you want to 
send data files to other people you need to send all of these helper files, not just the .shp one.

Other shapefile helper file types will appear...

...if moving/copying/sending make sure you include them all!
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QGIS Project Files

• QGIS loads up project files (extension: .qgs).

• It's important to remember each project only stores references to files for each layer. Edits 
to layers must be saved separately.

• Project files define what you see on screen: 

◦ which layers, in what order

◦ how layers are styled

◦ what labels are displayed

◦ viewing area

• Multiple projects can reference the same shapefiles – so editing layers in one project will 
show up in another. Hence the importance of file housekeeping!

Initial (one-time) set up

1. Open QGIS. If using a laptop, you may find it useful to connect a mouse.

The default co-ordinate reference system should be set to OSGB 1936 (EPSG: 27700) – 
the Ordnance Survey 6 figure grid for the UK.

2. Settings>Options

3. Go to the CRS tab on the left. 

◦ Select Enable on-the-fly reprojection.

◦ Select Use default CRS displayed below.

◦ Using the Select button, set both default CRS fields to EPSG:27700 - OSGB 1936 / 
British National Grid. You may need to type 'OSGB' into the 'Filter' bar to find it and 
select '27700' .

Alternatively you could select 'WGS84' (for world lat/long data); GPS or satellite data may come in 
this format but will automatically be reprojected over our OS grid system

OSGB/1936 EPSG7405 is for 3D work and can mix things up a bit – avoid these options for now!
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Exercise 1 – Vector (shapefile) basics

In this exercise you will learn basic manipulation of map data imported from the Ordnance Survey.

1    Add some shapefiles

1. Layer>Add Layer>Add Vector Layer

2. Next to Dataset, select Browse and
navigate to Exercise 1 – Basics then the 
Shapefiles folder from the files supplied.

3. Narrow the search field by selecting 
ESRI Shapefiles (*.shp  *.SHP) as the
file type, and then select all the .shp files
listed (by pressing Ctrl and clicking on
each one). Click Open twice.

4. You will see that the four shape files have appeared in the Layers panel on the left. The files
may have loaded in the wrong order so that your county areas cover your settlement points –
drag the layers up and down until they are in the following order:

settlement_point east anglia points villages/towns/cities

river_polyline east anglia polyline (line) rivers

woodland_region east anglia polygon  (area) woodlands

county_region east anglia polygon  (area) county bondaries

Data available from Ordnance Survey © Crown Copyright 2014 available here: 
https://www.ordnancesurvey.co.uk/opendatadownload/products.html 
These files are subsets of the Meridian2 shapefiles

2    Save Save SAVE!

There can be a tendency for QGIS to crash, so save often!

1. Project>Save. Alternatively, click the Save  icon.

2. Navigate to the Exercise 1 – Basics folder (above the Shapefiles folder)

3. Enter a file name Exercise 1 Map, and click Save.

Save repeatedly and often throughout these exercises.

5

 

https://www.ordnancesurvey.co.uk/opendatadownload/products.html


3    Setting colours and styles
QGIS will automatically assign colours to your new layers. You most likely want to change these!

1. Right click on river_polyline east anglia and then open Properties and go to  
the Style tab.

2. Click the Color box and choose a blue (or colour of your choice) using the dropdown menu.
Press OK twice to return to the map canvas. If you can't see the river lines, you may need 
to reorder the layers in the left-hand menu by clicking and dragging this point to the top of 
the list.

3. Choose suitable colours for your other layers. Note: polyline areas have border and fill 
colours. There are many other style options: Transparency, line width etc...

4    Viewing attribute data

Right click on settlement_point east anglia and then Open Attribute Table. 

For each point on the map, there is a row in this table. Much of this is OS system data but the
column for attribute NAME0 contains plain text with the name of each settlement. 

You can close this table or leave it in the background. You don't need to do anything with this for
now.

5    Label points with an attribute

We are going to label each settlement point on the map with its name (NAME0) – this may be slow!

1. Right click on the layer and open Properties, then go to the Labels tab on the left.

2. Tick Label this layer with and select NAME0 from the dropdown list. Set the size to 10 points
(i.e. always size 10 font on screen. Setting to 10 map units will make the labels 10m tall on 
the map!).

3. Do the same for the  river_polyline east anglia layer to display river names in a different  
style (Note: you select NAME rather than NAME0 for this option).

In  Properties>Labels there  are  many  options  in  the  latest  version  of  QGIS  for  displaying
(rendering) labels.
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Text: basic font, colour, size options.
Formatting: text alignment, line wrapping for long labels.
Buffer/background/shadow: adds  a  buffer  or  shadow  around  text  for
readability (this can become a headache if you export to a graphics package like
Adobe Illustrator or Inkscape later).
Placement: where the label appears in relation to the  map point. The Priority
feature at the bottom refers to how important this layer's labels are relative to
others. The new 'clever' labelling engine in QGIS may not display all labels for
all layers all the time!

Press OK to close the Properties and have a look around the map. To navigate, click on the 'hand'
icon to move the map to the location you are interested in,  and click on the zoom in and out
buttons to view greater or lesser detail (see below). 

Your map should now look a little like this...

It's still  'busy'  so we'll  filter out some place
names, just displaying the ones we want.

A scale bar would be useful:

1. View>Decorations>Scale Bar.

2. Tick  Enable  Scale  Bar (and  adjust  
the scale to your requirements).

6    Filtering (querying) data

Because of the attribute data attached to each point, we can tell  QGIS to filter which points it
displays.

1. Right-click on  settlement_point east anglia,  select  Properties,
open the General tab on the left, then open the Query Builder
(you may have to scroll down to find it). 

2. Type in a query that  looks like this,  using the buttons where
applicable:
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NOTE: you need to double click on 'NAME0' to select it. You can add more place names, but
make sure they have single inverted commas and a comma between each one.

3. Before closing the dialog box, Press Test at
the  bottom  and  it  will  tell  you  how  many
results  match that  query,  or  if  you made a
mistake! But note: it won't tell you if you spell
a  town  name  wrong.  When  you're  happy,
press OK twice to get back to the map.

4. Repeat for the river_polyline east anglia: this
time  we'll  exclude any rivers with no name
(presumably  smaller  ones).  This  query
expression is a bit different:

Now look at the Attribute Table again (or re-open it
by Right click on settlement_point east anglia and
then  Open  Attribute  Table).  It  is  now  much
shorter, but the underlying shapefile still contains
all the original data. The map is less cluttered and will load more quickly now.

NOTE: this reduced query is only set by this project. You could have a different QGIS project using
the same shapefile at the same time and show all  or a different subset of place names if you
wanted.
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7    Identify Tool

This tool allows you to click anywhere in the map canvas and retreive attribute data for selected 
shapes. This has changed with version 2.6. First only works on selected layer. Then have to 
change Mode from 'Current Layer' to 'Top Down'. 

This is another one-time setup task: 

1. Select the Identify Features icon in the top bar.

2. Click on an area of the map you are interested in, e.g. a river or settlement point. A dialog 
box entitled Identify Results appears. Use the dropdowns to find relevant information.

3. If you wish to keep the dialog box accessible, you can drag it into the lefthand pane of the 
QGIS window.

Exercise 2: Working with rasters

In this exercise we will work with some raster data (pixels, images). This includes freely available 
OS Maps, scanned OS and historical maps, aerial photos and other types of data. Create a new 
project: 

1    Add the background maps 

1. Project>New.

2. Layer>Add Layer>Add 
Raster Layer.

3. Navigate to Exercise 2 – Raster
and Georeferencing, then 
Raster Maps

4. Open the four  .tif files (not  the
corresponding  .tfw files).  Your
cmoputer may not list the .tif files
as this – so just select the files
which aren't .tfw. 

5. This may generate a warning about CRS – ignore this.

2    Georeferencing

This is the process of taking an image with no spatial data or reference points (scanned maps or
aerial  photos) and locating them on our map projection. QGIS does this by taking the original
image file and some reference points and producing a new georeferenced file and displaying it on
our map.
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3    Scanned OS Map

The advantage here is that the Ordnance Survey Explorer Map has a grid printed on it, so we know
where each point is.

1. From the top menu, select  Raster>Georeferencer>Georeferencer. Sometimes this feature
is not installed or enabled, in which case go to Plugins>Manage and Install Plugins... and
search for 'Georeferencer'.

2. Open the scanned Explorer Map of Cambridge: File>Open Raster. Navigate to Exercise 2 –
Rasters and Georeferencing,  and then select  Raster Scans,  and  209 Cambridge.jpg. This
could take a while, since the file is quite large.

3. Zoom in to Madingley, just west of Cambridge, to show several km on screen. As with the
main canvas window you can pan by holding the middle mouse button down and zoom in and
out  by scrolling  up and down,  or  click  on the 'hand'  icons and 'zoom in'  and 'zoom out'
buttons.

We are going to map the grid point north of Madingley wood onto our map canvas (TL4060 but we
have to use the full 6 figure reference 540000 260000).

4. Select the 'Add point' tool, and click
on the grid point where the 40
easting meets the 60 northing (TL 40 60).

Enter  X  =  540000  and  Y  =  260000  (see
right). Press OK.

5. We need a second point. Scroll east to the
other  side  of  Cambridge,  just  east  of  Fen
Ditton. Add a new point where the 50 Easting meets the 60 Northing (TL 50 60).

Enter coordinates X = 550000 and Y = 260000 and press OK.

6. Press the  Start Georeferencing (play) button (if not present on the screen, it's under
'File') and it will ask you to set some transformation settings first time. 

7. Set:

◦ Transformation  type: Helmert  (this  is  
'scale and rotate' and only requires the  
two reference points we've given.

◦ Resampling method: Cubic (a bit slower
but better quality)

◦ Compression: LZW  (a  bit  slower  but  
results in smaller files)

◦ Click  the  file  symbol  next  to  Output  
Raster and it will automatically fill in the 
new  file  name  as  209  
Cambridge_modified.tif, then press Save.

◦ Target  SRS should  already  be  set  to  
EPSG:27700 (so the output image is in  
OSGB coordinates).

◦ Make  sure  Set  Target  Resolution is  
Unchecked for  now  (this  is  a  more  
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advance option for tweaking the output file size and quality but it can easily go wrong!).

◦ Check Use 0 for transparency and Load in QGIS when done.

◦ Press OK (takes a little while).

10. Minimise  the  Georeferencer.  In  the
Layers panel, move this new layer to the
top of the stack, if not there already. You
should have a picture like this (see right).

11. Right  click  on  this  layer,
Properties>Transparency.  Change  its
transparency to 70%. Click OK. 

You should now be able to see the OS
Open  Data  maps  through  the  scanned
OS Explorer map.

12. Look  around  the  map  now.  You'll  see
near our reference points it matches well
but further away it may have drifted out.
This is okay for now, but we may want to
repeat  the  process  using  two  points
further apart to tighten it up.

13. If  you  look  in  the  Raster  Scans  folder,
you'll see there are several additional files
generated. The  .tif file is the new image and normally quite large. The original  .jpg file is
unaffacted.

4    Scanned Historic Map

The first edition 1 inch Ordnance Survey Map does not have the modern metric OSGB grid printed
on it, so we can directly use grid coordinates. Fortunately we can specify points where it fits on the
map canvas so QGIS can position it correctly.

1. Open the georeferencer window again
(Raster>Georeferencer>Georeferencer).

2. File>Open Raster>45_Cambridge 1st Ed 1inch.jpg

3. Zoom and pan across to Fulbourn in the south-east corner.

4. Click the Add point tool and click on the T-junction south of the 'n'
in Fulbourn (see right).

5. Now instead of entering co-ordinates, we can get them
automatically from the main map canvas. Click From Map Canvas.
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6. Without clicking the left mouse button pan across the main
map (using the middle button and scrolling to zoom) to the
same point in Fulbourn and then click on it:

7. You will be returned to the georeferencer window. Click OK.

8. Repeat  with  another  point  near  Girton  at  the
north-western  corner  of  the  map.  The  road
junction  near  the  south  of  the  village  is  a
landmark that has not moved:

Press Play. 

9. Close the georeferencer (agreeing to Save GCP
Points) and adjust the transparency of the new
layer to about 40%.

You should be able to see that the maps agree. If not, you may have to repeat the process,
checking you have to right reference points. The resulting image is ugly but useful. You can
turn different layers on and off at the side to help.

5    Georeferencing an Aerial Photograph

We use the same process for georeferencing/rectifying photographs. Ideally shots should be as
close  to  perpendicular  as  possible,  however  it  is  possible  to  rectify  oblique  shots  relatively
accurately.

In this example, I have already created GCPs (ground control points) which will load when you
open the photo.

1. Open the Georeferencer.

2. File>Open Raster... and choose to  Cmglee_Cambridge_aerial.jpg (from the Raster Scans
folder).  
This  file  is  available  from  wikipedia  under  a  Creative  Commons  License
http://en.wikipedia.org/wiki/Cambridge#mediaviewer/File:Cmglee_Cambridge_aerial.jpg

3. The reference points have already been defined for you and should appear automatically.

4. Press Play, and it will prompt you to set up the
Transformation Settings.

5. This  time  set  the  Transformation  Type to
Projective.

6. Set the Output Raster file name (it will fill in a
name  for  you)  then  press  OK.  Leave  the
Georeferencer.
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Note: whenever you are asked to save points after working with an image, just press OK to save
as the default file name. 

The  resulting  image  is  badly
distorted  because  the  original  was
so oblique. However, most features
match  up,  even  4-5km  away  from
the  camera  (try  increasing  the
transparency  of  the  layer  to  check
against the map below).

6    Perpendicular View

Doing this with historic (particularly RAF) aerial
photographs allows you to trace features which
may not appear on any of your maps. 

For  example,  this  photo  of  Fowlmere  Airfield
shows the airfield's layout between editions of
the  OS map  before  the  old  field  boundaries
were re-established.

The perimeter track (now ploughed away) had
shown  up  in  geophysics  as  an  unknown
feature, but was never shown on OS maps.

Study area: red; perimeter track: blue.

Image downloaded from wikipedia: 
http://en.wikipedia.org/wiki/RAF_Fowlmere#mediaviewer/File:Fowlmere-13April1947.png
Public domain
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Exercise 3 – Importing Data

QGIS will open a lot of different spatial file
types, usually the only hitch is with
different coordinate systems but it will
normally open them and reproject them on
the fly for you.

1. Start a new project (saving the old
one). Project>New.

2. Most files can be imported by going
through Layer>Add Layer>Add
Vector Layer, selecting Browse,and
changing the file type filter. Or more
easily, drag from your file manager
straight into the Layers panel.

3. Do this for each of the files in the
folders:

Exercise 3 – Importing>KML - for
google earth KML files

Exercise 3 – Importing>GPX - for handheld GPS tracker files. Select one file (do the second 
after the first is loaded). GIS will ask you which sub-layers to import, just choose track 
points. Repeat for the second layer.

You should now have two track_points layers and since these example shapes aren't located near
each other, a useful function is to right click on a layer and click Zoom to layer. This will frame the
map around the extents of the chosen layer.

Usually you will want to edit this data, but currently these files aren't editable. To make changes
(add attribute data, add or delete shapes) you will need to save these layers as shapefiles.

1. Right click on a track_points layer and click Save As.

2. Format: select 'ESRI Shapefile' from the file types.

3. In the Save As line, click Browse to find the file Exercise 3 – Importing/Shapefiles and call
it 'Track Points'. Click Save, and then OK.

In order to make changes to a layer and commit them to the shapefile, you first have to  enable
(toggle) editing for that layer. Select the new Track Points layer, right click on it, then click Toggle
Editing.

At this point, you can add attributes of your own and add or delete points or change the style of the
lines, display them over other maps etc. This could be useful for displaying fieldwalking data or for
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Exercise 4 – Fieldwalking Results

An  imaginary  field  walking  exercise  has  been  undertaken,  results  have  been  recorded  in  a
spreadsheet, and exported as a CSV file. Grid co-ordinates were known for the south-west corner
of each grid square of 10m sides.

We are going to take this data and display it with symbols appearing at the x,y representing the
data at that coordinate.

1    Importing CSV Data

1. Start a new project.

2. Import the CSV file by adding it as a new layer Layer>Add Delimited Text Layer.

3. Browse and select Exercises 4 – Fieldwalking/CSV/Fieldwalk 60x100.csv 
(or you can drag and drop it into the layers folder).

4. QGIS will need to know how to read the file, so tweak the options until the sample table looks 
correct by ticking CSV (comma separated variables) and First record has field names

5. Set the X field and the Y field to come from the appropriate columns (named x and y here).

6. Press OK.
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2    Displaying Symbols

Initially we see every point as a uniform dot, whether there were finds there
or not. We need to adjust the styling of the layer's points according to the
data  we  have,  so  right-click  on  the  filename  in  the  Layers  panel,  open
Properties and go to the Style tab.

1. Change  Single  Symbol  to  Graduated in  the dropdown menu.  This
allows us to specifiy different symbols depending on data attached to
each point.

2. Select the data Column we want to use (e.g. 'rb pot').

3. Select  a  memorable  Color  ramp from  the  drop  down,  then  press
Classify. This will generate a selection of symbols for each value for rb
pot. 

4. Initially symbol values will be overlapping, so double click on the value in each case and set
the ranges to 1-1, 2-2, 3-3 etc. You can also add a class for 5-10 by selecting Add Class.

5. You can change the style of  each symbol  by double clicking on it  (size,  colour,  different
symbols even – E.g. you could make 5-10 a larger circle.

6. Press OK to see the results. Hopefully the 0 values have disappeared
from the map, leaving the hot spots highlighted (e.g. see right). 

7. This only shows our rb pot points. We can look at others instead by
changing the column used in the Style tab. 

Try switching the data column to flint or med pot. You might want to
adjust the symbol value ranges for these other data views.

If you wish to display two of these results at once, you have to add the CSV
file again (see Step 2). Your project will then have TWO layers refering to
the same data, but each with their own styling. You could do this for all of the data columns or just 
switch between them to show one at a time.
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Print Composer

GIS is a useful tool for overlaying different spatial data to enable analysis – without reaching for the
photocopier, acetate and overhead projectors. However, it is likely that you will want to distribute 
the images you have created.

You can think of a print composer as representing a page. You can have multiple print composer
for a project, so one might show a view (map) of the project at 1:100 and another at 1:500. If you
make changes to the project, the results are then reflected in both composers at their scales.

 The print composer system in QGIS enables you to export images in a variety of formats. 

• png -     a web-friendly raster image format

• svg -     vector format for use in Adobe Illustrator or Inkscape

• pdf -     vector (i.e. zoomable on screen) pdf useful for sharing but can sometimes be 
                  overcomplicated and load slowly.

You can also print directly from a print composer, although this can have undesired results! It is
usually safest to create a PDF and print from there. For professional reports, its best to do the final
polishing,  styling,  moving  labels  etc.  in  a  graphics  package  to  ensure  report  figures  are  all
consistent.

How Print Composers work

Each project can have a number of print composers. A print composer represents a printed page or
output image area so you can specify A3, A4, A5 etc. from the start. You can manage these from
the Composer Manager (Project>Composer Manager...)

Each print composer can have multiple 'Maps'. These are numbered Map 0, Map 1... as you add
them to the page. Normally you would only want one map on a print composer sheet.

Each map on the page will display all the layers currently 'switched on' in your project. You can
specify the scale and move the contents around. You can also display a grid and coordinates within
or outside the map.

For Starters...

1. Project>New Print Composer. Give the file a name, and click OK. 

2. Click  the  Add  new  map  button. Draw  a  box  on  the  Print  Composer.  It  grabs  
whatever is on your screen.

3. You can add more than one map by zooming in and out of your original map and then  
capturing images at different scales on the same page on the Print Composer. But:
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Tip: If you want different maps on a page to display different layers, you have to tick Lock 
layers for map item for one map, then change the displayed layers and do the same for the 
second map. The problem comes when you want to change this later or add a new one in 
since you have to repeat the process! Often it is simpler to display everything, export the image 
as an SVG and then use Illustrator/Inkscape to delete layers or labels you don't want.



You can add additional map decorations:

• scale bars (associated with each map) can be customised

• legends/keys for each map

• images (such as logos)

• text

• arrows and arbitrary shapes
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