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Step by Step Guide to using Snuffler to Process 

FM256 Magnetometry Surveys 
 

This guide is based on training and notes provided by Peter Masters of Cranfield University. 
Some additions and amendments have been made by Jigsaw Cambridgeshire to adapt the 
guide for our volunteers; any errors are our own. Thanks to David Staveley for creating this free 
user-friendly processing software. 
 
 
Snuffler is an excellent freeware alternative to commercial software packages such as Geoplot 
and TerraSurveyor (formerly Archeosurveyor) used by professionals as it offers similar features 
(destriping, interpolation, creating greyscale maps) and functionality (e.g. downloading data from 
instruments).  
 

Installation 
Snuffler can be downloaded at 
http://www.sussexarch.org.uk/geophys/snuffler.html  
 
1. Under ‘Page Index’, click on ‘Download’. The 

current version is 1.12. Where it says 
‘Download the file here: snuffler.zip (5.6Mb)’, 
click on ‘snuffler.zip’ and select ‘Save file’. Once 
downloaded, save the .zip file into a folder of 
your choice (e.g. C:\Snuffler) and double-click 
on ‘snuffler.zip’ to open the file. Then double 
click on ‘setup.exe’ file. A standard Windows-
type installation wizard will pop-up (see right). 
Follow the instructions to load the program.  

 
 
 

 
 

 
2. It will also ask you for the installation folder (e.g. 

C:\Snuffler). Click on ‘Next’ to start unpackaging the 
program. 

 
(It is important to note that Snuffler works fine 
running Windows XP but you might find that some 
functions may not work as well with Windows 7 and 
8.) 

 
3. Once the installation is complete, a 

Snuffler shortcut should appear on your 
Desktop (see right). Double click on it to 
run the program.  

 

 

http://www.sussexarch.org.uk/geophys/snuffler.html
http://www.sussexarch.org.uk/geophys/snuffler.zip
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Create a Project  
Once Snuffler is installed, create a new project. Go to 
File>New Project (see right). A pop-up menu will appear 
(see below). Name your project something memorable and 
click on ‘Create’. Your project name will appear in the left 
margin in Snuffler. 
 

 

 
 
 
 

 

 
Importing/Downloading Data 
There are two basic ways of entering geophysics data into Snuffler. One is to directly 
download the data from the Geoscan FM256 instrument and the other is to import previously 
downloaded data in ASCII (.dat, .xyz, .txt) format into your project. 
 
 

Method 1: Direct Downloading 
1. Connect the FM256 to your computer using the Data Dump nine-pin cable. If your computer 

doesn’t have a nine-pin cable, you may use the green USB adaptor, but it is not always 
possible to download using this. To ensure good results, use an old PC or laptop with a nine-
pin female Comm Port, or borrow the Jigsaw laptop. 

 
2. Turn on the FM256. We need the FM256 to be in ‘Fast ASC’ mode. To ensure this is 

selected,  
 
 

press                       on the FM256 instrument. Then select ‘Setup’ by pressing  
 
 
 

and using the down key                   navigate to find ‘Data Format’ and then use the left and  
 

 
right keys to select ‘Fact ASC’. Once this is selected press the                          button twice 
to exit the menu. 

 
 
 
 
3. Back in Snuffler, select File>New>Import file 

(see right). 
 
 
 
The ‘Meter Import’ menu will appear (see right). 
Select the following: 

Dump 

End Menu 

Menu 

0 

Dummy 

Log 

3 

Delete 
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 Import Name: give a slightly different 
name to above, e.g. testdata. 

 Hardware: ‘FM256 MAGNETOMETER’. 

 Comms Port: this refers to the port in 
the computer into which you connected 
your FM256 Data Dump cable. Select 
the Comms Port, e.g. COM1. If you 
don’t know which port it is, you may be 
able to check this in the Device 
Manager on a Windows OS. 
Alternatively, use trial and error – if it 
doesn’t download with COM1, try COM2 
etc. 

 Grid Split: check the ‘Split into Grids 
Now’ box to avoid data mix-ups later on. 

 Grid Prefix: file name again e.g. ‘test’. 
 
 
 
Follow the instructions at the bottom of the ‘Meter Import’ box to complete download. 
 
 
 
4. If download has been successful a Data Order Selector box appears (see 

right). Untick ‘horizontal progression’ and it should go up and down 
from bottom left. 

 
5. Turn off the FM256. 
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Method 2: Importing Previously Downloaded Data 
It is best to directly download your data directly from 
the FM256 before you return the equipment. 
However, Snuffler can process data from imported 
files (e.g. if you ask Jigsaw to download the data into 
Geoplot, we can send you the data files to process in 
Snuffler). 
 
1. Make sure the files you want to upload are in the 

correct folder. Save the .xyz or .dat file as 20x20 
not 80x20 (4 readings/m) in Geoplot. Import .xyz 
data into Snuffler by putting it into Program Files 
(x86)/Snuffler folder.  

 
 
2. File>Import>Easy XYZ Import Into New File 

(see right). Navigate to the folder your files are 
stored in and select your first file. A new box 
appears (see below): 

 
 
 
   Select: 
   Origin: ‘Bottom-Left’  
   Dummy value: 2047.5 (Geoplot) 
 
 
 
 
 
 
 
 
 
 
 

 
 
3. Continue in this vein until all the required files have been entered into your project. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Creating a Composite 
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Once your data has been incorporated into your Snuffler project you can preview each grid. To 
the left of your file name you will find a ‘+’ sign. Click on this, and the title ‘Geophysics Data’ 
appears. Click on the ‘+’ sign next to this as well, and the file names of each of the grids 
uploaded are listed. Right-hand click on the name of the grid you wish to preview, and select 
‘Preview Window’ (see right). A sneak preview of your grid will appear. 

 
 

 
 

 

In order to view all the data in one view a composite needs to be created: 
 
1. Go to File>New>Map File (see right). 
 

The ‘New Map’ box appears (see below): 
 

 
 
 

 

 Map Name: e.g. ‘testcomp’. 

 Map Width and Map Height: this refers to the layout and number of the 
grids you surveyed. For example, the diagram on the right represents the 
Map Width: 3 and Map Height: 2. 

 
 
Press ‘OK’. The following box appears: 
 

 
 

 
 
 
 
 
 
2. Now you need to attribute each 

grid to its proper location. Left-hand click on one of the ‘Empty’ grids. A ‘Select Data Source’ 

  1   2   3 

 

  6   5   4 
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box appears. Select a filename to fill this box according to the order you surveyed the grids 

in, e.g. see below.  

 

 

 

 

 

3. Once the grids have been configured into their correct positions you can close the 

Composite file (the program will ask you whether to 

save the file – select ‘Yes’).  

4. Click on the ‘+’ sign next to ‘Maps’, right-hand click 

on the composite filename (e.g. ‘testcomp’) and 

select ‘Spawn Main View’. Give it a new filename, 

e.g. testcompView (see right) and click ‘OK’.  

 

You should now be able to view all your data. 

  

 

 

 

 

 

 

 

 

 

 

 

 

Processing the Data 
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Your raw data will look something like the image (right). Due to the fact that raw magnetic 
data usually suffers from several defects that originate from the physical principles of the 
method, several basic steps (filters) need to be undertaken in order to create a clear and 
functional visualization of the acquired data. The sequence and parameters of these filters is 
important as too much processing can lead to either the obscuring of factual data or of 
creating new, false anomalies.  
 
 
 

 

Destriping 
The first defect that is visible on the greyscale plot is the heading error that is caused by bad 
adjustment of the gradiometer and also by temperature shifts that cause the sensors to 
change their zero base point. A destriping (alternatively Zero Mean Traverse) algorithm may 
be used in order to remove this defect: 
 
Go to Filters>Destripe 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A ‘Destripe’ box will appear (see right). 
 
For ‘orientation’, select ‘horizontal’ if the stripes are horizontal 
(as in the example above), and select ‘vertical’ if the stripes are 
vertical.  
 
Click ‘OK’. The worst of the stripes should have been removed 
from your data. 

 
 
 
 
 
 

 
 

Despiking 
Another algorithm that can make the visualization clearer is the “Despike” filter that removes 
small dipolar anomalies that are caused by ferrous detritus in the topsoil and also by bad 
instrument-handling during measurements. The application of this filter requires the input of 
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a threshold and type of flattening effect. Caution is advised as too much filtration in this case 
will cause a great amount of false data to be incorporated into the plot. 
 
Go to Filters> Remove Spikes. The ‘Despike’ box appears (right). 
Experiment with the settings. ‘Sit on it like a moose’ means ‘heavy 
despiking’ so select this option if you suspect the instrument wasn’t 
handled well (e.g. in first or second time the operator used the 
FM256), or if there was a high magnetic content in the topsoil. 
 
 
 
 
 
 
 
 
 
 
 
 

Interpolation 
Now data defects have been removed, the dataset can now be interpolated: new data is 
added to give it a smoother look. 
 
Go to Filters>Interpolate. The ‘Interpolate’ box appears 
(right). Choose ‘Interpolate Horizontally and Vertically’ 
and click ‘OK’.  
 
 
 
 
 
 
 
Your data should now look smoother and more 
processed, as in the image (right): 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Contrast & Colour Manipulation 
Snuffler offers a few basic display types and processes. 
These can be switched on by selecting the following: 
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1. Select Display>Next Process Type (see right). This changes the type of visualization 
type from dot density to relief map. If you repeatedly select Display>Next Process Type 
you can scroll through the different available views. 

 
 
 
 
 
 
 
 
 
 
2. Select Display>Next Display Type. This changes the colour pallete 

used to visualize data. Again, if you repeatedly select Display>Next 
Display Type you can scroll through the different available views, e.g. 
see right.  

 
 
 
 
 
 
 
 

3. Another thing that can be done in order to 
adjust the display type to your needs is 
the contrast manipulation of the data.  
 
Select Display>Display Settings. The 
‘Display Settings’ box appears (see right): 

 
 
 
 
 
 
 

 
Snuffler by default uses the ‘Auto Recalc Using Above’ option. You can turn this off by 
unticking the box next to it, and entering your own range of data to compare the results.  
E.g. enter Low: -10 and High: 10 and note the different level of information that is now 
visible on your magnetic map. You can also choose the Display Process and Display Type 
directly from this menu. 
 
 
 
 
 

Exploring data: measuring distances & angles 
Snuffler also provides basic measurement tools for further interpreting the data. These can 
be accessed from the icons on the toolbar. 
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Measure Angle icon. Select this and then click on two points on the data which you wish to 
measure the angle between. 
 

 
Measure Distance icon. Select this and then click on two points on the data 
which you wish to measure the distance between. 
 

You may find it useful to use the Increase Mag (zoom in) and Decrease Mag (zoom out) 
buttons to calculate angles and distances between points more accurately. 
 
 
Another very helpful feature in Snuffler is the ability to see the coordinates and geophysical 
signal of the place currently below the cursor. This is shown in the lower left corner of the 
window (see below, marked by the red rectangle). As you move the cursor around over the 
image the different readings will be shown. 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

 
 
 
Adding grid lines 
To enhance interpretation, you may find it useful to add 
the original grid lines to your data. This can be 
achieved by clicking on the ‘Display Grid’ icon (see 
below). Your data should now have grid lines as shown 
in the image (right). 
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Display Grid icon 

 
 

 
 
 
 
 
 
Raster Exportation & Further Possibilities 
Unfortunately in its current form Snuffler does not possess features that allow for the 
construction of a useful print plot nor has it any drawing/vectorization tools. Fortunately there 
is other freeware and open source software available such as QuantumGIS (QGIS) that 
used in conjunction with Snuffler allow for a fully professional & georeferenced plot to be 
created. 
 
In order to transfer our filtered data into third party software a raster of the acquired 
geophysical image needs to be exported. Snuffler currently only supports the .png format.  
 
Go to File>Export>PNG File (see below) 

 
 
 
 
 
 
 
 

 
A ‘Save As’ box appears. Give your file a suitable name and click ‘Save’. The saved file can 
now be imported into graphics software programs such as QGIS or printed and distributed in 
this form.  

 
 

 
 
 

 
 

 
 


